Cloudflare issue causing certificate expiration
Incident Report for HOA Express
Resolved
We’re resolving the incident after monitoring the fix for the last four hours.
Posted Nov 11, 2024 - 14:04 CST
Monitoring
A fix has been put into place by our email account provider, and we’re monitoring the results.
Posted Nov 11, 2024 - 10:05 CST
Identified
We’ve identified an issue on Cloudfare’s end that is causing an expired SSL certificate for our email account platform to be presented. We’re working with Cloudflare’s team and our email account provider to resolve the issue.
Posted Nov 11, 2024 - 08:54 CST
This incident affected: Third parties.