Unexpected downtime

Incident Report for HOA Express

Resolved

The deployment completed, and the incident is now resolved. We will be looking further into what caused the unexpectedly high load and will be taking steps to prevent this from occurring again with future deployments.
Posted May 20, 2026 - 13:25 CDT

Identified

A deployment to production with new features is putting unexpectedly high load on one of our platform’s databases, causing highly elevated error rates across our platform.
Posted May 20, 2026 - 13:15 CDT
This incident affected: Community websites and Admin Portal.