Calendly outage (call scheduling)

Incident Report for HOA Express

Resolved

Calendly has resolved the outage on their end.
Posted Jan 12, 2026 - 12:06 CST

Identified

Calendly, our provider for scheduling calls and video chats with our customer success team, is currently down. Calendly’s team is aware of the issue and is posting updates to their own status page here: https://www.calendlystatus.com/incidents/jsgq6jpfx08f. We’ll continue to monitor their updates.
Posted Jan 12, 2026 - 09:46 CST
This incident affected: Third parties.